1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Problem in jdeveloper, using adf faces

Discussion in 'Oracle Forms and Reports' started by ppbrnrd, Nov 10, 2008.

  1. ppbrnrd

    ppbrnrd Guest


    Well i am new using JDeveloper, i am using the version I am following some tutorials about using ADF Faces. I created a JSF - JSP under the web tier, but when i try to insert a PANEL PAGE to define a layout of my page, i am supposed to see a layout containing BRANDING, MENUS, MENU GLOBAL, ETC...(i mean, a grafical layout). When i try to insert an image under the branding section, i don't see a thing.

    When i run the JSP...i see the grafical layout, including the image i inserted under branding...

    I know it's a simpel issue, but i am new using ADF Faces, and i don't know why i can't see the grafical view of my jsp in jdeveloper (i am in the design window of the jsp), but somehow it works when i run de jsp and i am able to see the pictures and the layout in the browser. I just see in the desing window something that says PAGE DIRECTIVE, but no pictures, no layout

    The problem here is...how could i design a jsp when i can't see the grafical representation in JDeveloper??? This issue must be related to a view button or option i can't find

    This is the source code of the jsp, which is supposed to let me see a grafical layout in the desing window (but it doesn't work in the design window...somehow it works when i run the jsp)

    I see just boxes in the jsp in which i am having problems

    --Just a little more info, in case it is necesary ****
    I have three application in my new JDeveloper.
    The first application is a working one (i can see the correct jsp in the desing window and everything works well)

    The second is a testing applicationi created, and it is called "PRUEBA ADF FACES" -->it include blanks in the name. It has a project named "prueba1 ADF" ---> it include blanks in the name. I had the same ploblem when i created my first jsf - jsp in it...but i don't know what i did...but the problem was solved...

    But then, i created another application using a template to have to projects...the MODEL and the VIEWCONTROLER. The problem appears when i create a JSF -JSP in the VIEWCONTROLER project

    Thanks in advance, i hope someone could help me with this issue...i've been trying to find a solution but i can't....

    Attached Files:

  2. callme_harry

    callme_harry Active Member

    Likes Received:
    Trophy Points:

    I'm newbie too.

    I have the same problem like you too. Based on my experience this is JDev bugs.

    Im do the following :
    1. Close all editor (File -> Close All)
    2. Restart JDev
    3. Re-open your file
    4. Oracle recommended using JSPX file then JSP, so use it.

    When working with JDev dont open to many files.

    Hope this help