1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Polish characters are missing through the sqlplus

Discussion in 'SQL PL/SQL' started by Revathi Thirunagari, Apr 19, 2018.

Tags:
  1. Revathi Thirunagari

    Revathi Thirunagari Active Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    80
    Location:
    Hyderabad
    Hi All,

    I have DMLStatements which contains some polish characters for POLAND country.
    When i am executing that DML through the QL Developer i am able to see my Polishcharacters.

    but when we gave the release through the SQLPLUS those characters are replacing with some special characters
    like ? (Question Mark)


    Data type of the column is : NCLOB
    NLS_CHARACTERSET : AL32UTF8
    NLS_NCHAR_CHARACTERSET : AL16UTF16

    Could you please help to resolve this

    Thanks
    Revathi T
     
  2. krasnoslobodtsev_si

    krasnoslobodtsev_si Forum Genius

    Messages:
    774
    Likes Received:
    147
    Trophy Points:
    830
    Location:
    Russian Federation
    Last edited: Apr 19, 2018
  3. Revathi Thirunagari

    Revathi Thirunagari Active Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    80
    Location:
    Hyderabad

    Hi
    [​IMG]
    krasnoslobodtsev_si


    Thank you very for interest to resolve the issue .
    We are linux environment .
    We tried by
    NLS_LANG=POLAND_POLISH.A32UTF8
    export NLS_LANG
    But that is not working
    Please help what setting we need to change st support

    Our Poli
     
  4. krasnoslobodtsev_si

    krasnoslobodtsev_si Forum Genius

    Messages:
    774
    Likes Received:
    147
    Trophy Points:
    830
    Location:
    Russian Federation
    your linux is ubuntu?
    run your sqlplus and execure this command
    Code (SQL):

    host echo $NLS_LANG
     
    what is result ?[/code]
     
    Last edited: Apr 20, 2018
  5. Revathi Thirunagari

    Revathi Thirunagari Active Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    80
    Location:
    Hyderabad
    After setting the following commands in the linux machine
    NLS_LANG=AMERICAN_AMERICA.AL32UTF8
    export NLS_LANG

    Thank you very much for your support Sergei Krasnoslobodtsev.