1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Issue with sending swedish characters to table via sqlplus

Discussion in 'General' started by rit_netsys, Oct 4, 2017.

  1. rit_netsys

    rit_netsys Starter

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    10
    Location:
    India
    We are using Oracle 12C database with below settings -

    Code (SQL):
    SELECT * FROM nls_database_parameters WHERE parameter LIKE '%CHARACTERSET';
    Result :
    NLS_NCHAR_CHARACTERSET UTF8
    NLS_CHARACTERSET AL32UTF8


    Windows client Environment Variable set to - NLS_LANG = AMERICAN_AMERICA.UTF8
    Windows Registry for Oracle set to - NLS_LANG = AMERICAN_AMERICA.AL32UTF8

    Now we are trying to insert Swedish characters to table via SQLPLUS -
    Code (SQL):
    INSERT INTO gen_barium_ucc_src_t (MI_INPUT_ID, "NAME", LOGIN_ID, USER_EMAIL, CC, STATUS, "ROLE", INS_DTIME ) VALUES ('96', 'Susanne Svärd', 'SUSA', 'S@abc', 'CC00007', 'ACTIVE', 'DEV', SYSDATE );
    While checking the same with SQL PLUS, it is showing Swedish characters perfectly.

    But while checking the same with SQL Developer GUI, it is not showing Swedish Characters properly in table . It is showing Swedish characters as "?".

    Then I tried to insert the same with SQL Developer GUI. Here Table is accepting Swedish characters properly.

    Is there something I am missing?
     

    Attached Files:

  2. zargon

    zargon Community Moderator Forum Guru

    Messages:
    2,541
    Likes Received:
    362
    Trophy Points:
    1,430
    Location:
    Aurora, CO
    Yes, the display settings for SQL Developer. Check to see what character set us set to display, I expect it's not a UTF8 variant.