1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Installation of j2sdk 1.4.2_09 on redhat machine

Discussion in 'JAVA, SOA and Application Development' started by sajocmathew, Jan 16, 2012.

  1. sajocmathew

    sajocmathew Guest


    I am working on a project which uses j2sdk 1.4.2_09. Previously, we were using Solaris machines to host the server. We are going to deprecate Solaris and want to move the Server to a Linux machine. I downloaded j2sdk 1.4.2_09 for Linux and then tried to install it on a 64 bit redhat machine. It failed giving the following error

    "./j2sdk-1_4_2_09-linux-ia64-rpm.bin: line 395: ./install.sfx.17803: cannot execute binary file"

    I tried installing the 32 bit version and got the following error.

    "./j2sdk-1_4_2_09-linux-i586-rpm.bin: ./install.sfx.18137: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory"

    Can somebody tell me how I should proceed.