1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

UCM workflow Issue, Content is not getting released even after approving content

Discussion in 'Oracle Webcenter Suite (formerly Oracle ECM)' started by amarpal.kaur@nvish.com, Mar 31, 2009.

  1. Hi,

    I am new to oracle UCM, so I have created a simple workflow for beginning. It has only one activity which triggers when some content of particular content type is checked. There is no script associated with any of the workflow events. Workflow is working fine except one issue.

    *When reviewer approves the content, workflow does not release the content and worflow is still shown in 'Active Workflows' list.* I cant see the content even in search as status of content remains 'Review'.

    Am i missing something ??

    Please guide!!!

    Thanks in advance
    Amarpal
     
  2. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    goto admin applets-->repository manager and check what is the status of the content. If it shows review it has not come out of the workflow. Let me know the status here.
     
    ah.yasar likes this.
  3. markH

    markH Forum Advisor

    Messages:
    88
    Likes Received:
    10
    Trophy Points:
    180
    Location:
    Kansas
    Contents will not appear in search untill they are released. so you can't search contents which are in workflow. If you want to see them you can either see them through the My workflow assignments..>active workflows or if you have repository manager access you can see from there.

    Regarding why content is not being released even after approval, what is there in the log file? Check the table workflowhistory to see what happened with the content.
     
    ah.yasar likes this.
  4. Thanks for replying,

    Sadik,
    Status of the content in repository manager is still Review.

    Mark
    I didnt find anything noticeable in Logs and workflowHistory table.


    For more details i have attached screenshot of active workflow page.
     

    Attached Files:

  5. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    could you please execute the code below and post the results.
    Code (Text):

    SELECT *
      FROM workflowhistory
     WHERE dwfname = 'RejectApproveWorkflow' AND ddocname = 'WORKFLOWTEST2'
     
     
    ah.yasar likes this.
  6. Result of the query is attached!!
     

    Attached Files:

  7. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    hi amar it's very difficult to read from the text file, could you just copy paste the results and put it here within
    Code (Text):
    [/B]your results [B][/ code][/B] (without the space) Blocks
     
    ah.yasar likes this.
  8. There are too many columns in the result set thats why its not displaying content properly in
    Code (Text):
     
    section.

    I am attaching a new file i hope you will be able to see the output this time.
     

    Attached Files:

  9. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    hmmm so u did approve the content. The table shows that your approve action was performed without any problems. Unless you have another step in your workflow or additional approvers required it should have been released.

    If it doesn't, I would suggest you disable this particular workflow (that will automatically release all documents with this workflow. Now create a new criteria workflow and keep a simple criteria based on type and keep just one step and one approver. Make sure you have value 1 in "at least this many reviewers".

    Now checkin a file of the type .Login as the approver and approve. Now if you do these steps correctly and there is no bug with your installation then your content should be released.
     
    ah.yasar likes this.
  10. ah.yasar

    ah.yasar Active Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    80
    thanx for the information sadik .
     
  11. cjelena

    cjelena Guest

    Hello,
    I have some issues with content entering workflow. I have set up workflow as collaboration project, with security group set as Project, and with criteria field set as Selected workflow to match the name of this workflow. Problem appear when I check-in content from collaboration project, with selectet workflow from above. It will never enter workflow, it is immediately stated as realeased. Any suggestions?