1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

'The provider is not compatible with the version of Oracle client error' popping up r

Discussion in 'Oracle Development General' started by stomas, Aug 14, 2013.

  1. stomas

    stomas Guest

    I've got 2 different applications in 2 different IIS folders on a webserver, each with several asp.net pages. They work fine for a period of time and then inexplicably a 'The provider is not compatible with the version of Oracle client error' gets thrown and affects all of my asp.net pages in both applications. A simple reboot of the server fixes the issue until the next time it happens but I can't identify any consistent point where this crash happens. This server has some older applications running on it that use an older version of the Oracle client but I have verified that my application is attempting to load the v11.2 client from the subfolders in my application folders (I verified this by deleting all of the Oracle DLLs and running the application again which threw a 'The resource cannot be found' error and goes back to the Oracle error after I copy the DLLs back to the bin folder). I had the same applications hosted on my local machine for a time and this never happened as well as it never happening when I run them in localhost. Any ideas what the problem could be?