1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

System error in site studio

Discussion in 'Oracle Webcenter Suite (formerly Oracle ECM)' started by Taranjit Singh, Jan 19, 2015.

  1. Taranjit Singh

    Taranjit Singh Active Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    Whenever I try to login into sitestudio, I get the below error and site studio shuts down:-

    System Error: Unable to create result set for query 'SELECT Revisions.dID, dDocName, dDocTitle, dDocType, dRevisionID, dSecurityGroup, dDocAuthor, dDocAccount, dRevLabel, dFormat, dOriginalName, dExtension, dWebExtension, dInDate, dOutDate, dPublishType, dRendition1, dRendition2, dFileSize AS VaultFileSize, DocMeta.* FROM DocMeta WHERE Revisions.dID=DocMeta.dID And Revisions.dID=Documents.dID And dIsPrimary = 1 AND dReleaseState IN ('Y', 'U', 'I') AND ((xWebsiteObjectType <matches> `Fragment`)) ORDER BY dInDate DESC''. DB2 SQL error: SQLCODE: -7, SQLSTATE: 42601, SQLERRMC: `;ObjectType <matches>)

    Sitestudio version: - 10Gr3
    Content server- 7.5
    can anyone please help me out?
    Thanks in advance..!!
     
  2. Vachow

    Vachow Guest

    SQL CODE:-007 SQLSTATE: 42601
    Means STATEMENT CONTAINS THE ILLEGAL CHARACTER invalid-character
    The specified invalid-character is not a valid character in SQL statements

    System Says:The statement cannot be processed

    Remedy: Check the statement for any special characters and remove them if any. Check for syntactical errors and correct them if any. and execute it.

    Also, execute the below steps and see if it helps.

    perform the following steps:

    Set in <content server install dir>/config/config.cfg, the var and value: "SkipUnicodeSQLQueryConversion=true".

    Restart all Content Server cluster nodes, or your single instance
     
  3. Taranjit Singh

    Taranjit Singh Active Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    Thank you for the update Vachow.

    I tried the following steps, but it didn't worked:

    Set in <content server install dir>/config/config.cfg, the var and value: "SkipUnicodeSQLQueryConversion=true".

    Restart all Content Server cluster nodes, or your single instance


    Also for the initial fix i.e.(Check the statement for any special characters.....), I am not sure, where to make the changes, as the error comes up on the start-up of site-studio and after that it just shuts down.
    Are there any changes to be done in the database or where are the changes to be done?