1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Steps to install Site Studio and other components

Discussion in 'Oracle Development General' started by rnavduri, Mar 4, 2009.

  1. rnavduri

    rnavduri Forum Advisor

    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    80
    Hi,

    I have recently installed Content server using the steps in this article: Installing Stellent or Oracle Universal Content Management. And later I have setup Site Studio. Here are the steps to install sitestudio along with other components like Dynamic converter.

    One more thing you need to know is there are two versions of Site Studio. One is 10gR3 and another is 10gR4. From someone I came to know that R4 is dropping the support of JSP it seems. Moving forward templates and fragments will use IDOC scripts only.

    Pre-Installation tasks:

    1. Before installing Site studio R4 or R3 create below components using Configuration manager Applet. There are seven (7) content types that we typically create for any WCM implementation. They are listed below as Name – Description:

    • Document – doc, pdf, ppt, xls, etc.
    • Image – photo, graphic, etc.
    • SS_FORM – Site Studio Form
    • SS_FRAGMENT – Site Studio Fragment
    • SS_LAYOUT – Site Studio Layout
    • WebAsset – CSS, JavaScript
    • WebContent – Data File, HTML

    2. Download Oracle Content Server - Document Management modules from Oracle Technology Network
    a. Unzip the DynamicConverter_10gR3_20071031.zip file (stored inside ContentServer_DocMan_10gR3_20071031.zip) in a separate folder under the staging area, e.g. C:\stage\UCM\DynamicConverter.
    b. Unzip the Desktop_10gR3_20071031.zip file (stored inside ContentServer_DocMan_10gR3_20071031.zip) in a separate folder under the staging area, e.g. C:\stage\UCM\DIS.​


    Installing Components like Sitestudio, Dynamic Converter and so on..


    1. Install the components shown in the table below by following these steps for each component:

    a. Start the Component Wizard (On Windows, using menus:
    Start > Programs > Oracle Content Server > idc > Utilities > Component Wizard)
    b. Click Install
    c. Click Select
    d. Browse to the specified .zip file (see below)
    e. Click OK
    f. Installation options: see below
    g. Wait for the installation to complete
    h. When asked if you would like to enable the component(s), click Yes
    Close Component Wizard​

    Component: Dynamic Converter
    FileName:C:\stage\UCM\DynamicConverter\component\DynamicConverter.zip

    Component: Desktop Integration Suite
    FileName: C:\stage\UCM\DIS\Component\DesktopIntegrationSuite.zip

    Component: EmailMetadata
    FileName: C:\stage\UCM\DIS\Component\emailmetadata.zip

    Component: Site Studio
    FileName: C:\stage\UCM\SiteStudio\Component\SiteStudio.zip
    Installation: Click OK to accept all

    When all components have been installed, restart Content Server


    2. Enable Fulltext Search
    a. Edit the SearchIndexerEngineName parameter in D:\UCM\config\config.cfg:
    b SearchIndexerEngineName=DATABASE.FULLTEXT
    c. Restart Content Server
    d. Rebuild the Content Server Index
    ****************************************
    ( How to rebuild indexes in Oracle Content Server?
    * Log in to Content Server How
    * Click Admin Applets
    * Click on the Repository Manager icon(if you are using Internet Explorer, you may have to click twice - the first click is interpreted as "I want to use this control")
    * Click the Indexer tab
    * In the Collection Rebuild Cycle, click Start​
    )
    *****************************************

    3. Set Default Project Document Information

    a. Log in to Content Server
    b. Click Administration
    c. Expand Site Studio Administration
    d. Click Set Default Project Document Information
    e. Scroll to the bottom of the page and click Update​

    4. Add Default Content Type (This part is very important as I got an error because I have not setup the default content type)

    a. Go to Configuration Manager How?
    b. Click Options and then Content Types
    c. Add the following Content Type:
    As Name, enter SystemFile
    As Description, enter System File
    As Image, select document.gif

    5. Add Default Conversion Template

    a. Create a blank template with Content ID BLANKTEMPLATE and Title Blank Template for DC​

    *************************************
    How to create a blank Conversion Template in Oracle Content Server
    * Log in to Content Server
    * Click Administration
    * Expand Dynamic Converter Admin
    * Click Check In Existing Template
    * As Content ID, enter BLANKTEMPLATE
    * As Type, select SystemFile
    * As Title, enter Blank Template for DC
    * As Primary File, browse to D:\UCM\custom\DynamicConverter\samples\gui_templates\Blank.ttp
    * Click Check In​

    *************************************

    b.Still in the Dynamic Converter Admin section, click Configuration Settings
    c. In the Default Template section, select BLANKTEMPLATE from the Available Templates dropdown list
    d. In the Conversion Formats section, select the following MIME types from the dropdown list to add them to the eligible formats:
    - application/msword
    - application/vnd.ms-excel
    - application/vnd.ms-powerpoint
    e. Scroll to the bottom of the page and click Update
    f. Verify that Dynamic Conversion is working:
    - Click New Check In from the top menu
    - Enter Content ID (e.g. MyDoc) and Title (e.g. My Document)
    - Browse to a Word document on your hard drive
    - Click Check In
    - On the Confirmation screen, click Content Info
    - Click HTML to the right of Get Conversion​


    Installing Site Studio Designer

    a. Start Installer:
    cd /d C:\stage\UCM\SiteStudio\Designer
    setup.exe
    b. Click Next
    c. Change Destination Location to C:\prog\UCM\SiteStudio\Designer
    d. Click Next
    e. Click Install
    f. Click Finish
    g. Start Designer: Start > Programs > Oracle Universal Content Management > Site Studio 10gR3 > Site Studio Designer
    h. When Site Connection Manager shows up, click New
    i. As Server Cgi URL, enter http://donald.disney.com/idc/idcplg
    j. Click Connect *
    k. Enter User Name and Password and click Login
    l. Click the New button to the right of the Site Label dropdown list
    m. As ID, enter MFS
    n. As Name, enter My First Content Server Site
    o. Click OK
    p. Click OK
    q. Click Done​


    Thats it, you have installed and configured sitestudio.

    Regds
    Rajesh
     
  2. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    Hey Rajesh, thanks for that excellent article. Just to add one point that all the components can also be installed from browser using the component manager screen. (For someone who doesn't have server access). Also I formatted the article a little for readability.

    Btw as an aside, since most users are in favor of it, an article section is coming up shortly. It is currently under development. Once it comes, this thread will be moved there.

    Regards
     
  3. rnavduri

    rnavduri Forum Advisor

    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    80
    Sadik,

    Feel free to make any changes to the document. I am just learning the stuff in my personal laptop. Thats the reason I have documented like that. I did not even think in that direction. No wonder you are the admin for this group.


    Rajesh
     
  4. markH

    markH Forum Advisor

    Messages:
    88
    Likes Received:
    10
    Trophy Points:
    180
    Location:
    Kansas
    Hey Rajesh, thanks a lot for these steps. It will be very useful for me in the future. thanks again
     
  5. prabhux

    prabhux Active Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    55
    Hi,

    Rajesh/Sadik

    Following the above step i'm able to install site studio successfully, however i'm not able to start site studio designer from window- start menu>>programs>>sitestudio. In login window after i enter user id and password.

    i'm getting the following error popup.
    "Failed to get search result with query "Fargment"


    i also difficulty at step 2.
    After changing SearchIndexerEngineName=DATABASE.FULLTEXT
    While Rebuild the Content Server Index .
    Inder abort error.


    I've attaced the Admin server log "error while login to site studio"

    ==========================================
    Event generated by user 'sysadmin' at host 'localhost'. Unable to retrieve search results. Unable to create result set for query 'SELECT index1.dID, dDocName, dDocTitle, dDocType, dRevisionID, dSecurityGroup, dDocAuthor, dDocAccount, dRevLabel, dFormat, dOriginalName, dExtension, dWebExtension, dInDate, dOutDate, dPublishType, dRendition1, dRendition2, VaultFileSize, WebFileSize, URL, dFullTextFormat, dFullTextCharset, DocMeta.*
    FROM index1, DocMeta
    WHERE index1.dID=DocMeta.dID AND ((xWebsiteObjectType LIKE 'Fragment')) ORDER BY dInDate DESC'. ORA-00942: table or view does not exist
    [ Details ]
    An error has occurred. The stack trace below shows more information.

    !csUserEventMessage,sysadmin,localhost!$!csSearchUnableToRetrieveSearchResult!csDbUnableToCreateResultSet,SELECT index1.dID\, dDocName\, dDocTitle\, dDocType\, dRevisionID\, dSecurityGroup\, dDocAuthor\, dDocAccount\, dRevLabel\, dFormat\, dOriginalName\, dExtension\, dWebExtension\, dInDate\, dOutDate\, dPublishType\, dRendition1\, dRendition2\, VaultFileSize\, WebFileSize\, URL\, dFullTextFormat\, dFullTextCharset\, DocMeta.*<br> FROM index1\, DocMeta<br> WHERE index1.dID=DocMeta.dID AND ((xWebsiteObjectType LIKE 'Fragment')) ORDER BY dInDate DESC!$ORA-00942: table or view does not exist<br>
    intradoc.common.ServiceException: !csSearchUnableToRetrieveSearchResult!csDbUnableToCreateResultSet,SELECT index1.dID\, dDocName\, dDocTitle\, dDocType\, dRevisionID\, dSecurityGroup\, dDocAuthor\, dDocAccount\, dRevLabel\, dFormat\, dOriginalName\, dExtension\, dWebExtension\, dInDate\, dOutDate\, dPublishType\, dRendition1\, dRendition2\, VaultFileSize\, WebFileSize\, URL\, dFullTextFormat\, dFullTextCharset\, DocMeta.*
    FROM index1\, DocMeta
    WHERE index1.dID=DocMeta.dID AND ((xWebsiteObjectType LIKE 'Fragment')) ORDER BY dInDate DESC!$ORA-00942: table or view does not exist

    at intradoc.server.SearchManager.retrieveSearchInfo(SearchManager.java:254)
    at intradoc.server.SearchService.retrieveSearchInfo(SearchService.java:1275)
    at intradoc.server.SearchService.doLocalSearch(SearchService.java:1045)
    at intradoc.server.SearchService.getSearchResults(SearchService.java:528)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at intradoc.common.IdcMethodHolder.invokeMethod(ClassHelperUtils.java:461)
    at intradoc.common.ClassHelperUtils.executeMethodEx(ClassHelperUtils.java:128)
    at intradoc.common.ClassHelperUtils.executeMethod(ClassHelperUtils.java:113)
    at intradoc.server.Service.doCodeEx(Service.java:505)
    at intradoc.server.Service.doCode(Service.java:470)
    at intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1350)
    at intradoc.server.Service.doAction(Service.java:450)
    at intradoc.server.ServiceRequestImplementor.doActions(ServiceRequestImplementor.java:1191)
    at intradoc.server.Service.doActions(Service.java:445)
    at intradoc.server.ServiceRequestImplementor.executeActions(ServiceRequestImplementor.java:1111)
    at intradoc.server.Service.executeActions(Service.java:431)
    at intradoc.server.ServiceRequestImplementor.doRequest(ServiceRequestImplementor.java:632)
    at intradoc.server.Service.doRequest(Service.java:1709)
    at intradoc.server.ServiceManager.processCommand(ServiceManager.java:357)
    at intradoc.server.IdcServerThread.run(IdcServerThread.java:195)
    ===========================================
     
  6. isaac2004

    isaac2004 Active Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    55
    prabhux

    did you configure Zone Text Fields?

    You can do that by logging in, Zone Fields Configuration
    then add Web Sites and Exclude from Lists into the left box. save and restart CS.
     
  7. prabhux

    prabhux Active Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    55
    Isaac,


    Thanks your valuable info. I'm very new to UCM.

    i confiqured zone text fields... I guess this problem was due to some error with domain index. i was unable search content id nor checkin content. This problem started after "collection rebuild cycle". I could'nt find the root cause but i uninstalled content server and dropped all the tables,tablespace form DB. Did it all over again from the scratch.Now wroking fine.

    Please someone tell me why this happend incase if this kind of problem occurs again whats the solution without loosing the contents checked in.
     
  8. pprudhiv

    pprudhiv Active Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    75
    Hi Prabhu,
    Same problem i am also facing. I did changing the zone fields too. still the issue is same.

    Any help in this?
    Regads,
    Pandu


     
  9. oraucm

    oraucm Active Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    55
    Hi,

    I am new with Site Studio. I am using UCM 10gR3 & Site Studio 10gR4. I installed SS with the help of "SS installation pdf guide".

    I am facing issue with SS now. When i try to create "page template". Assign Form is showing few script error.

    Today I visited this page and reviewed all my installation. Follow the same as u mention. But still same error.

    Error Screen attached.

    Please help to resolve this.
    Thanks.
    oraucm