1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

.rtf showing error message

Discussion in 'Oracle Forms and Reports' started by DEEPAK THAPAK, Jul 15, 2015.

  1. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Dear all,
    at the time of running . rtf, it showing error.kindly solve it.
    error message "
    at java.lang.reflect.Method.invoke(Unknown Source)
    at oracle.apps.xdo.common.xml.XSLT10gR1.invokeNewXSLStylesheet(Unknown Source)
    at oracle.apps.xdo.common.xml.XSLT10gR1.transform(Unknown Source)
    at oracle.apps.xdo.common.xml.XSLTWrapper.transform(Unknown Source)
    at oracle.apps.xdo.template.fo.util.FOUtility.generateFO(Unknown Source)
    at oracle.apps.xdo.template.fo.util.FOUtility.generateFO(Unknown Source)
    at oracle.apps.xdo.template.FOProcessor.createFO(Unknown Source)
    at oracle.apps.xdo.template.FOProcessor.generate(Unknown Source)
    at RTF2PDF.runRTFto(RTF2PDF.java:629)
    at RTF2PDF.runXDO(RTF2PDF.java:470)
    at RTF2PDF.main(RTF2PDF.java:289)
    Caused by: oracle.xdo.parser.v2.XPathException: Error in expression: './/CF_6<=:CF_cutoff_date'.
    at oracle.xdo.parser.v2.XSLProcessor.reportException(XSLProcessor.java:806)
    at oracle.xdo.parser.v2.XSLProcessor.newXSLStylesheet(XSLProcessor.java:571)
    ... 14 more"

    Thanks & Regards
    Deepak Thapak
     

    Attached Files:

    Last edited: Jul 15, 2015
  2. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Hi,

    We are not getting any error.
     
  3. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Hi,
    unfortunately error have been corrected, but xml showing two record and .rtf showing one record.simply i want to put one condition in if1(cf_6<=cf_7) only.kindly suggest me.
     
  4. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    First use for-each:group syntax, then only it will repeat the rows.
    Use like this...

    <?for-each:G_1[( CF_6<=CF_7)]?>

    also remove end if and use <?end for-each?>
     
  5. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Hi,
    when i done this it not showing any row.here i attached .rtf & xml file also.
     

    Attached Files:

  6. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Hi,

    Use this in for each form field.

    <?for-each:G_1[( CF_6<=../../CF_7)]?>

    Hope this will work
     
  7. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Hi,
    As per above syntax, condition return wrong statement.
     
  8. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Hi,

    Condition is wrong or syntax?

    Try like this also...

    <?for-each:G_1[( CF_6<=(../../CF_7))]?>

    if you want >= then you can replace
     
  9. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Hi,
    Same issue,Condition is wrong.
    In .XML three records, two records need to be showing....
     
  10. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Hi,

    Do you want Aug record or not?
     
  11. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
  12. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Ok,

    It's because of date. I tried by replacing number instead of date in .xml file. It's working perfectly.
    So will think of date.
     
  13. DEEPAK THAPAK

    DEEPAK THAPAK Active Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    80
    Hi,
    plz suggest,what to do in .rdf.if possible plz do & send to me.
     
  14. jagadekara

    jagadekara Forum Guru

    Messages:
    1,126
    Likes Received:
    145
    Trophy Points:
    1,805
    Location:
    Pulivendula
    Hi,

    in rdf for cf_6 and cf_7 display days instead of date. Then same condition will work.

    To display days use like this....

    to_char(to_date(your_date_col),'yyyyddd')

    Note that there may be other ways. As per my knowledge I gave this solution for temporarily, If I got another will let you know...