1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

ORA-02005: implicit (-1) length not valid for this bind or define datatype

Discussion in 'General' started by tripower, Aug 24, 2010.

  1. tripower

    tripower Active Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    55
    I am getting the following error dialog when trying to run even the simplest of queries in SQL Tools:

    ORA-02005: implicit (-1) length not valid for this bind or define datatype

    The system engineer made a simple change in TNSNAMES to point to the correct server. SQL Navigator works just fine. But I cannot get SQL tools to work anymore and I have already tried re-installing. Any help is appreciated.
     
  2. zargon

    zargon Community Moderator Forum Guru

    Messages:
    2,351
    Likes Received:
    348
    Trophy Points:
    1,430
    Location:
    Aurora, CO
    No change to the tsnames.ora file will cause this error. It is caused by passing a -1 to a define statement or possibly because of a version mismatch between the GUI and the client. You need to know the version of the database you are using and the versions of the database the tool supports. You may also need to upgrade the SQL Tools installation.

    Check the documentation for SQL Tools.
     
  3. lino_gonza

    lino_gonza Guest

    1) Check first if the database you are using is compitable with SQL Tools version by going to SqlTool Help->About

    2) If compatible make sure to uncheck bind variables settings such as:
    a) Session Menu > Enable DBMS output
    b) Script Menu > Enable Substitution variables

    Hope this helps
     
  4. nelson_mario

    nelson_mario Guest

    Hi Tripower.

    Open REGEDIT.
    HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE

    Your must add a new ALPHANUMERIC value: ORACLE_SID
    Use a valid TNSNAMES ORACLE SID Values.

    Restart SQLTOOLS.

    I hope it can help you.

    NELSON MARIO R.
    Bogotá.