1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

ORA-01882: timezone region not found

Discussion in 'General' started by SudeepShakya, Jul 25, 2011.

  1. SudeepShakya

    SudeepShakya Active Member

    Messages:
    33
    Likes Received:
    1
    Trophy Points:
    90
    Location:
    Kathmandu,Nepal
    i connected oracle from oracle sql plus successfully but i tried from jDeveloper but it failed and the message displayed is:
    Test failed: ORA-00604: error occurred at recursive SQL level 1
    ORA-01882: timezone region not found
    please its urgent
     
  2. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    1. Go Tools > Project Properties then

    2. (Project Properties) open select Run/Debug/Profile > in right you will see Default > Double click here or click Edit
    3. (Edit run configuration) select Launch Settings > in 'Java option' text item past this line -Duser.timezone="+06:00"
    4.close and re-open JDeveloper
    5. Run entire project

    Good Luck!
     
    SudeepShakya likes this.
  3. SudeepShakya

    SudeepShakya Active Member

    Messages:
    33
    Likes Received:
    1
    Trophy Points:
    90
    Location:
    Kathmandu,Nepal
    i did same as you instructed
    As i am using jDeveloper 11g the process was bit different
    1. go Applications->Default Project Properties
    2. open Run/Debug/Profile > in right i see Default > Double click here or click Edit
    3. (Edit run configuration) select Launch Settings > in 'Java option' text item past this line -Duser.timezone="+05:45" my local time is Kathmandu,Nepal
    4.close and re-open JDeveloper
    And i tried to connect to oracle database
    Unfortunately it didn't worked sir the error message was the same as previous
    Thank You for your fast response
     
  4. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    Try this,

    AddVMOption -Duser.timezone="+05:30" (add this line to jdev.conf)
    -Duser.timezone="+05:30" (each projects run profile)
     
    SudeepShakya likes this.
  5. SudeepShakya

    SudeepShakya Active Member

    Messages:
    33
    Likes Received:
    1
    Trophy Points:
    90
    Location:
    Kathmandu,Nepal
    yes it worked
    thank you very much
    you are great!!!!!!!!!!!!!
     
    Sadik likes this.
  6. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    You are welcome! :)
     
  7. rusirumalik

    rusirumalik Guest

    To fix it in jdeveloper 11g R2 ,you need to add following lines into [ide folder]-> ide --> bin --> ide.conf

    1AddVMOption -Duser.timezone="+05:30"