1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Fast Formula Erroring out

Discussion in 'Oracle Apps Technical' started by vamsioracle, Apr 7, 2009.

  1. vamsioracle

    vamsioracle Forum Expert

    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    140
    Hi all,

    I have a problem with the fast formula and i am unable to find which function has the error.
    The error mesg is :

    Formula BG_ABSENCE_DURATION: ORA-01403: no data found ORA-01403: no data found Cause: During the PL/SQL execution part, an Oracle error was detected. Action: Please refer to your system administrator.


    How can i find the exact error source.

    vamsi


    --------------


    I asked the DBA at the client side to check the code. he has sent me the script of the formula.

    The actual code in fast formula has a function shown below

    GET_HOLIDAYS(L_Leave_Type,L_Year_start_date,L_Year_End_date,date_start,date_end)


    the same function in the script sent by the DBA is lik this

    T2:=FFFUNC.NC(UDFS_PKG.GET_HOLIDAYS(D1,D2));

    My doubts are.

    Inspite of changing the code atthe front end why is it like this
    how can i changeteh code.

    vamsi
     
  2. apps_expert

    apps_expert Forum Expert

    Messages:
    325
    Likes Received:
    28
    Trophy Points:
    330
    Location:
    Chennai, India
    You can debug your fast formula by returning mesg statements at different stages in your formula. If your formula isn't too complex you should be able to find the exact cause.

    Alternately you should use the PYUPIP tool to anayse trace files of the fast formula. Actually I have a document which will explain everything to you. Read this and you should be able to resolve your problem.
     

    Attached Files:

    manpurbhoo likes this.
  3. vamsioracle

    vamsioracle Forum Expert

    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    140
    I could find out some starange behaviour.

    When i apply leave using Leave of Absence in teh Self Service, it errors out wheni give both start date and end date.

    If i remove end date, then i am able to apply leave without any error.

    Isn't it something strange.



    vamsi
     
  4. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
    not really. It depends on how your formula is being evaluated out. Apparemtly when you are giving the end date there is a problem with your formula script. Did you try and debug as apps_expert suggested?