1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Cannot find LOV view object (XxiSupplierEmpLoVO1) in LOV AM.

Discussion in 'JAVA, SOA and Application Development' started by ijazasim, Mar 27, 2013.

  1. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Dear All,

    I created customized LOV using following Steps.

    1. Create a New Workspace and Project
    2. Create a New Application Module (AM)
    3. Create a New View Object (VO)
    4. Add View Object to Root UI Application Module
    5. Create a New Page
    9. Create a New Region.
    10. FTP all the files on $JAVA_TOP
    11. Run Import commond
    12. Attaching External LOV to Page

    When I click on torch button to get the LOV result it gives error.

    Cannot find LOV view object (XxiSupplierEmpLoVO1) in LOV AM.

    if anyone know the solution please let me know.

    Regards,

    Ijaz Asim
     
  2. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    So, Plz do the following to verify a potential cause of the issue.
    1. Locate the AM in the Applications Navigator and click on it.
    2. In the Structure, Check the View Object Instances attached to it. Does it contains the XxiSupplierEmpLoVO1 instance? (Do remember that it is CASE-SENSITIVE)
     
  3. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    Thanks for your prompt reply.

    I have checked the XxiSupplierEmpLoVO1 view object is attached with AM. Please check the below import command which i run to import the files on server.

    import C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects\xxisupplier\oracle\apps\fnd\EmpLov\webui\XxiSupplierEmpLovPG.xml -username apps -password cpcerpapps -rootdir C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects -dbconnection "(DESCRIPTION= (ADDRESS=(PROTOCOL=TCP)(HOST=10.60.200.233)(PORT=1526))(CONNECT_DATA=(SID=UAT)))"

    import C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects\xxisupplier\oracle\apps\fnd\EmpLov\webui\EmployeeLovRN.xml -username apps -password cpcerpapps -rootdir C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects -dbconnection "(DESCRIPTION= (ADDRESS=(PROTOCOL=TCP)(HOST=10.60.200.233)(PORT=1526))(CONNECT_DATA=(SID=UAT)))"

    I also checked LOV screen about this page it is showing standard AM is attached with it. But when i run the page on client machine it is running fine and dispaly the records.

    Please help me out.

    Thanks once again

    Ijaz Asim
     
  4. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    I believe b4 importing it to server, you must have tested or debugged it at design-time. Whats the behavior at design-time? .. If u haven't then plz confirm it by running the page from your local m/c and then if any exception is encountered, paste the complete error stack here.

    *PS: I doubt its an importing problem.
     
  5. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    I also doubt that its importing problem. I tested and run the isuppiler page on locacl machine and it is running fine. I am able to get the desire results.

    Please let me know the steps how to import the files on server. It might be I am missing some steps.

    Thanks & Regards,

    Ijaz
     
  6. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Dude !!

    The import commands u posted earlier has got spaces within the file address path.
    I believe u've taken care of such bizarre errors while importing. And also u've confirmed ur importing. Did u get the import confirmation after running the import command?

    Anyways, Plz do the following to verify whether the importing has been done properly:
    Code (PL/SQL):

    BEGIN
    jdr_utils.listdocuments('/oracle/apps/fnd/EmpLov/webui',TRUE);
    END;
     
    Code (PL/SQL):

    BEGIN
    jdr_utils.printdocuments
    (p_document => '/oracle/apps/fnd/EmpLov/webui/XxiSupplierEmpLovPG');
    jdr_utils.printdocuments
    (p_document => '/oracle/apps/fnd/EmpLov/webui/EmployeeLovRN');
    END;
     
    Post the output of the above scripts.
     
  7. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    After run the import commands I got confirmation "import has been completed" Please find attached the results / output of test scripts which your provied.

    Regards,

    Ijaz
     

    Attached Files:

  8. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    This looks perfect. But then why isn't it working? .... mmm .. :confused:

    Describe your complete deployment Step-By-Step in detail. Don't miss out even a minute information.
     
  9. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    The following steps I used to create custom LOV.

    Step 1: Create a New Workspace and Project

    Workspace Name : xxEmployeesLov.jws directory name default click ok
    Project Name: xxEmployeesLov & default directory name
    Default Package: xxsuppliers.oracle.apps.ap.fnd. pmlov Click Next
    Select DBC file and enter required User & password, and responsibility information and click finish

    Step 2: Create a New Application Module (AM)

    Package: xxsuppliers.oracle.apps.ap.fnd. pmlov.server
    Name: EmployeesLovAm

    Step 3: Create a New View Object (VO)

    Package: xxsuppliers.oracle.apps.ap.fnd. pmlov.server
    Name: EmployeesLovVO
    What kind of data do you need this view object to manage?
    Read-only Access
    SQL Qeuery : Select employee_number, full_name
    From per_all_people_f
    where person_type_id = 1120
    and sysdate between effective_start_date and effective_endate

    Step 4 : Add View Object to Application Module

    Step 5 : Create a New Page

    Page Name: EmployeesLovPG
    Package: xxsuppliers.oracle.apps.ap.fnd.pmlov.webui

    Step 6: Select the EmployeesLovPG and go to the strcuture pane where a default region has been created

    Select region1 and set the following properties:
    ID: PageLayoutRN
    AM Definition: xxsuppliers.oracle.apps.ap.fnd.pmlov.server.EmployeesLovAM
    Window Title : List of values
    Title : List of values Demo

    Step 7: Right click PageLayoutRN and click new Region

    ID : MainRN
    Region Style: messageComponentLayout

    Step 8: Create a New Region

    Right click on xxEmployeesLov > New > Web Tier > OA Components > Region
    Name : EmployeesLovRN
    Package: xxsuppliers.oracle.apps.ap.fnd.pmlov.webui
    Region Style: listOfValues
    Scope : Public

    Step 9 Select EmployeeLovRN Right click on EmployeeLovRN in Structure pane and click table using wizard. In the wizard choose the xxsuppliers.oracle.apps.ap.fnd.pmlov.server.EmployeesLovAM and select the EmployeesLovVO1. Click Next

    Region Id : EmployeesLovTable
    Region style: table

    Step 10: Shuttle the two attributes to the right side.That is EmployeeNumber and FullName Click next, check the mapping and then finish

    Step 11: Select the field FullName and set the following properties:

    Search Allowed : True
    Selective Search Criteria: True

    Step 12: Click on EmployeesLovPG and right click the MainRN and click new messageLovInput and set the following properties:

    ID: FullName
    External Lov: /xxsuppliers/oracle.apps/ap/fnd/pmlov/webui/EmployeeLovRN
    Prompt : Employee Name

    Step 13: Select LovMap

    Lov Region Item: FullName
    Return Item : FullName
    Criteria Item: FullName

    Step 14:
    Run the page on local machine successfully

    Step 15: Transfer files from local m/c myclasses folder to #JAVA_TOP (/xxsuppliers/oracle/apps/ap/fnd/pmlov)server and webui

    Step 16: Run the below import commands

    import C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects\xxsuppliers\oracle\apps\ap\fnd\pmlov\webui\EmployeesLovPG.xml -username apps -password cpcerpapps -rootdir C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects -dbconnection "(DESCRIPTION= (ADDRESS=(PROTOCOL=TCP)(HOST=10.60.200.233)(PORT=1526))(CONNECT_DATA=(SID=UAT)))"
    import C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects\xxsuppliers\oracle\apps\ap\fnd\pmlov\webui\EmployessLovRN.xml -username apps -password cpcerpapps -rootdir C:\JDeveloper\OAF\R1213\jdevhome\jdev\myprojects -dbconnection "(DESCRIPTION= (ADDRESS=(PROTOCOL=TCP)(HOST=10.60.200.233)(PORT=1526))(CONNECT_DATA=(SID=UAT)))"

    Thanks,

    Ijaz
     
  10. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    How did u transfer the files to JAVA_TOP? FTP? Did u zip the project package folder from myclasses or just FTPed the folder?

    Ok i dunno if there's any difference, coz i know there isn't but still i would say .. Try importing the PGs and RNs from the server once, re-import the files from the server. Usually i do the same (although as far as i know it hardly makes any difference). Still try once.

    Manier times it doesn't behave the way desired, then re-importing resolves the issue.
     
  11. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    I transfered the files to JAVA_TOP using FTP software. Please let me know the commands for zip.

    Regards,

    Ijaz
     
  12. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Firstly, zip the project package folder (in ur case it might be xxsuppliers) on ur local m/c. Then FTP the zipped folder under a pre-defined directory xxsuppliers in JAVA_TOP.

    Doing this u'll have a directory named xxsuppliers under JAVA_TOP, and inside the directory u'll be having the zipped folder u FTPed.

    Then from unix server, navigate to the xxsuppliers directory and unzip the zipped folder by [highlight]unzip xxsuppliers.zip[/code]

    Then run the XMLImporters to import the PGs and RNs from the server itself.
     
  13. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    I done the steps as you told, but the problem is still there. I import the PGs & RNs from local machine.

    Thanks & Regards,
    Ijaz
     
  14. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    As i mentioned earlier, try importing the PGs and RNs from the server itself.
     
  15. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    Can you please send the import command and path in ther server.

    Thanks & Regards,

    Ijaz
     
  16. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    From Unix Server Shell, change directory to the $JAVA_TOP.
    Code ( (Unknown Language)):

    cd $JAVA_TOP
     
    Then from this directory import the PGs and RNs to the MDS repository.
    Code ( (Unknown Language)):

    java oracle.jrad.tools.xml.importer.XMLImporter $JAVA_TOP/<PG/RN file path with extension> -username <username> -password <password> - dbconnection "(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<Host Name>)(PORT=<port>))(CONNECT_DATA=(SID=<SID>)))" -rootdir $JAVA_TOP;
     
    *Note: Please replace the '<>' with relevant values. For E.g: <Host Name>, <SID>.
     
  17. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    I followed the steps which you told me but the problem is still there.

    Regards,

    Ijaz
     
  18. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    Was the apache server bounced after the importing? .. Please ask ur DBA or whoever is handling to bounce the apache server.
    As the changes done take some time to setup and bouncing is required. So just bounce it once and wait for some time may be 1 hr or so and check it once again if it has taken effect.

    If still the problem remains, then
    Login to System Administrator and submit a concurrent request for the program "Function Security Menu Report". It has got two parameters 1. Application and 2. Responsibility. So provide the application and responsibility where u've assigned the functions.
    And then in the output, locate the functions u've registered.

    If it shows up there properly, that means the functions are loaded properly or else wait for some more time or else charge up to ur DBA as to bounce the apache server properly.
     
  19. ijazasim

    ijazasim Active Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    125
    Hi Ari,

    I used WinRAR software and ziped the files with zip extension adn transfer from local machine to $JAVA_TOP then used unzip command to unzip the folder. in last i run import command from server as you told before.

    Regars,
    Ijaz
     
  20. ac.arijit

    ac.arijit Forum Advisor

    Messages:
    217
    Likes Received:
    22
    Trophy Points:
    280
    Location:
    Kolkata, India
    Hi Ijaz,

    I believe u ignored my last update on this.