1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Calling request throug backend

Discussion in 'Oracle Apps Technical' started by yknev, Mar 3, 2010.

  1. yknev

    yknev Active Member

    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    100
    Dear All,

    I am unable to run Standard Program request through backend using the follwoing coding:-

    MY Program Name is "PAYABLES TRANSFER TO GENERAL LEDGER".

    DECLARE

    Req number;
    l_boolean boolean;

    BEGIN
    l_boolean := fnd_request.set_mode (TRUE);
    req := fnd_request.submit_request ('APGLTRANS','APXGLTRN','','',FALSE,CHR (0));

    IF req = 0
    THEN
    DBMS_OUTPUT.put_line ('Not Submitted');
    ELSE
    DBMS_OUTPUT.put_line ('Submitted with ID ' || req);
    END IF;
    END;

    but it print "NOT SUBMITTED"(because the output of request is 0)

    I have mentioned the Log file below, after running the request through front end.

    report=/appltop/applmgr/erpappl/ap/11.5.0/reports/US/APXGLTRN.rdf

    batch=yes
    destype=file
    desname=/appltop/applmgr/erpcomn/admin/out/ERPT_iodindr/o3311448.out
    desformat=/appltop/applmgr/erpappl/fnd/11.5.0/reports/HPL

    Plz help me regarding the same .

    Thanks inadvance.
     
  2. Sadik

    Sadik Community Moderator Forum Guru

    Messages:
    1,906
    Likes Received:
    252
    Trophy Points:
    1,455
  3. yknev

    yknev Active Member

    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    100
    Dear Sadik,

    Already refered that Thread and practised in my test system but it shows above mentioned error. Plz let me know any discripancy in above program.
     
  4. a_kamalraj

    a_kamalraj Forum Advisor

    Messages:
    121
    Likes Received:
    23
    Trophy Points:
    280
    Hi,

    When you are running a Concurrent request using
    req := fnd_request.submit_request
    You need to pass all 100 parameters when you are running from backend. if no value for parameter please pass null value for tat and then try it will work out.

    Cheers
    Kamal