1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

-bash: ulimit: open files: cannot modify limit: Operation not permitted

Discussion in 'General' started by oraclepig, Sep 30, 2009.

  1. oraclepig

    oraclepig Active Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    I receive this error on my linux server with oracle installed when i try to su - oracleid. Can someone help with resolving this?
     
  2. cdemirel

    cdemirel Active Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    55
    you increase a ulimit parameter on linux in .bash_profile file for oracleid

    Cetin
     
  3. oraclepig

    oraclepig Active Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    Cetin

    Can you give an example of how to do this, what the entry would look like? Thank you
     
  4. cdemirel

    cdemirel Active Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    55
    cat >> /etc/profile <<EOF
    if [ \$USER = "oracle" ]; then
    if [ \$SHELL = "/bin/ksh" ]; then
    ulimit -p 16384
    ulimit -n 65536
    else
    ulimit -u 16384 -n 65536
    fi
    umask 022
    fi
    EOF


    Cetin