1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Apex upgrade failed from 4.1.1 to 5.0.2 version in oracle 11g database

Discussion in 'Oracle Application Express (APEX)' started by sunil, Dec 21, 2015.

  1. sunil

    sunil Active Member

    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    140
    Location:
    MICHIGAN
    Hi,
    The APEX upgrade has stopped suddenly when i was running apexins.sql. Later, i reverted back to 4.1.1 version. But here APEX now became invalid.
    COMP_ID COMP_NAME SCHEMA PROCEDURE VERSION STATUS
    ------------------------------ -----------------------------------------------------------------------------------------------------
    APEX Oracle Application Express APEX_040100 VALIDATE_APEX 4.1.1.00.23 INVALID
    ===================================================================
    When i checked into it. the 2 packages are invalid
    [​IMG]

    ...Database user "SYS", database schema "APEX_040100", user# "1207" 21:54:34
    ...FAILED CHECK FOR "PACKAGE BODY" "WWV_FLOW_DYNAMIC_EXEC" ORA-24344: success
    with compilation error 21:54:34
    ...command: "alter package APEX_040100."WWV_FLOW_DYNAMIC_EXEC" compile body"
    21:54:34
    ...DBMS registry set to invalid for APEX 21:54:34
    ...FAILED CHECK FOR "PACKAGE BODY" "WWV_FLOW_ERROR" ORA-24344: success with
    compilation error 21:54:34
    ...command: "alter package APEX_040100."WWV_FLOW_ERROR" compile body" 21:54:34
    ...Compiled 0 out of 2896 objects considered, 2 failed compilation 21:54:35.
    ============================================================
    Here, we are using database version below.

    SQL> SELECT * FROM V$VERSION;

    BANNER
    --------------------------------------------------------------------------------
    Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production
    PL/SQL Release 11.2.0.3.0 - Production
    CORE 11.2.0.3.0 Production
    TNS for Linux: Version 11.2.0.3.0 - Production
    NLSRTL Version 11.2.0.3.0 - Production
    ==============================================
    [​IMG]
    So, Could you please help in fixing this issue.
    [​IMG]
     
  2. GiriMani

    GiriMani Starter

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    10
    Location:
    chennai
  3. DTSIGuy

    DTSIGuy Forum Advisor

    Messages:
    402
    Likes Received:
    58
    Trophy Points:
    410
    Location:
    Texas
    What APEX environment are you upgrading? All I've ever done (on a Windows installation) is download the new APEX version, read the install instructions and do what it says...and it's worked every time.

    CJ
     
  4. sunil

    sunil Active Member

    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    140
    Location:
    MICHIGAN
    Hi,
    I have upgraded to 5.0.2 Apex environment during the 12c database upgrade. It went successfully with no issues.

    FYI:
    COMP_NAME VERSION STATUS
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- ------------------------------ --------------------------------------------
    Oracle Application Express 5.0.2.00.07 VALID

    thanks,
    Sunil