1. Get rid of all advertisements and get unlimited access to documents by upgrading to Premium Membership. Upgrade to Premium Now and also get a Premium Badge!

Abnormal program termination with Oracle universal installer

Discussion in 'Installation - Windows' started by moiram, Jan 19, 2009.

  1. moiram

    moiram Active Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    55
    My Oracle Universal Installer won't run. I've tried running as administrator - I get:

    Abnormal program termination. An internal error has occurred. Please provide the following files to Oracle Support:
    "Unknown"
    "Unknown"
    "Unknown"

    Now what?
     
  2. tyro

    tyro Forum Genius

    Messages:
    368
    Likes Received:
    20
    Trophy Points:
    260
    Location:
    India
    Are you trying to install or uninstall? If you are trying to install, you may have a corrupt download. Try downloading again.

    Also could we have a look at the log file?
     
  3. moiram

    moiram Active Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    55
    I'm trying to uninstall. While I've been using the 10201 client for awhile, it turns out I need a Vista specific client for some third-party tools. Where would I find the log file?

    Thanks,

    Moira
     
  4. tyro

    tyro Forum Genius

    Messages:
    368
    Likes Received:
    20
    Trophy Points:
    260
    Location:
    India
    Typically the log file would be in <oracle directory>/inventory/logs folder. Read this from oracle documentation.
     
  5. moiram

    moiram Active Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    55
    Hmmm... my <oracle directory>/inventory folder doesn't have a logs folder. And since my OUI doesn't run, it doesn't "display the name and location of the current session's log file on the Install page".

    I thought about downloading the client I want to install and see if that OUI can clean up after the corrupted one, but I'm a little worried about making a bigger mess!
     
  6. tyro

    tyro Forum Genius

    Messages:
    368
    Likes Received:
    20
    Trophy Points:
    260
    Location:
    India
    the OUI is a java utility, is your jdk installed properly. Try and upgrade your jdk. also which version of oracle r u trying to uninstall?

    However if all else fails, you can always manually remove oracle completely from your machine. If you have metalink access, read Note: 124353.1 It is an excellent article that describes how to manually perform the actions to create a "clean machine" on Microsoft Windows 95/98/NT/2000/XP and how to manually remove all Oracle components (e.g.: oracle RDBMS database server, IAS, OEM, client installations, etc) and services from your computer.
     
  7. tyro

    tyro Forum Genius

    Messages:
    368
    Likes Received:
    20
    Trophy Points:
    260
    Location:
    India
    Also try this location for the log file <oracle home>\cfgtoollogs\oui
     
  8. moiram

    moiram Active Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    55
    The only logs are there are from the original install on 10/1/08.
     
  9. nadimka

    nadimka Guest

    Moira, login using a local account (Create 'new user' if there is not one) and not a network/domain account to perform the task. Local account/user like 'oracle' should be part of the administrators. Once you login as oracle, you should be able to perform the installation or uninstallation without any issues.
     
    Sadik likes this.
  10. mithunashok

    mithunashok Guest

    Access this article which has a video shows how to install and get through Abnormal program termination error with OUI.

    mithunashok.com/2011/08/abnormal-program-termination-internal.html

    Regards,
    Mithun
     
  11. P1978

    P1978 Active Member

    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    65
    Location:
    Newmarket
    I was having the same problem, I totally scrubbed my PC and started from scratch and it seamed to install fine and everything seems to work now. :)